Images from airtable not syncing

Hi I am having issues with images today.

Images names are coming over from airtable but the data seems to be corrupted. I have tested with different image formats and still the same issues. Any idea what I can do to fault find this?

Screenshot 2024-03-11 at 12.11.54

@Kieran would you be able to share with us a URL to one of those records so we could investigate this a bit more?

Yes of course.

Here you go:

What sort of files are these @Kieran ? Are they actually PNGs?

Looking at the file it looks like we had trouble fetching it from Airtable - I wonder was this during some of the issues they recently had

Do you know when these were added?

Hi Darragh

Just yesterday, I added PNG and jpeg etc.

I will try again now.

Just had a go with new images, still the same issue very Strange!

Two are showing blank previews and the other is —

@darragh Wonder if someone can help me with the images - I am getting the issue now where sometimes the image will show and some times not. I am using a viability rule on the section, could that be a possible cause?

Happy to send over a video if that helps?

Hi @Kieran - is it just those images? You’ll need to remove them from Airtable and re-upload them I believe.

We did identify an issue which was causing this to happen and we believe we have patched it, so this won’t happen again.

Hi Darragh

I have tested with new images and removed them from airtable and all sorts of other tests (uploading from noloco database view for example)

Really stumped as to what’s going on. Any help would be appreciated as I have a deadline to go live at the end of this month.

1 Like

To anyone following along this issue.

We have identified and fixed the underlying issue with syncing Airtable images to Noloco

It looks like Airtable changed how files are originally represented on their end, so we just needed to make a minor update.

All new files should sync over as expected.

For any files/attachments that failed to upload while this issue was present, they will need to be re-uploaded, or just let us know and we can assist you.

Thanks @Kieran for the help debugging this