Linking/Unlinking related records no longer working


I have a page which has numerous collections of related records and I have enabled the ability to link/unlink records which was working fine before but I have today added a new collection and attempted to link an existing record to it but after clicking the record to add just got the spinning circle briefly and the record wasn’t linked. I’ve since tried to link and unlink records on the other collections on the page and nothing happens…

Tried reloading the page in case my browser was doing something funky but no joy.

Here’s a link to the page, the “Admins” collection is the new collection that I’m trying to link records to, but you’ll see it’s not possible to link or unlink records on the other collections either. [Redacted]

Hey @EthosLuke

The field you’re using as the related field is regions (from managers (user)) collection on the User table, which is a read-only field, which is why the linking/unlinking isn’t working.

In truth it shouldn’t be an option, but that’s something we’ll fix!

I would guess the field is a lookup (from the managers field) which would make it read-only

Aha, so the field is actually on the Region’s table in AT and is a user field called Managers (user), I’m sure this was working previously via the collection component but maybe I’m going mad - makes absolute sense that it doesn’t and so I’ve moved them to a details component now.