Date format incorrect

Hello!

We’re based in the Republic of Ireland. Dates are appearing in US format (mm/dd/yyyy) and not UK/Irish format (dd/mm/yyyy). I’m using Chrome/Windows 10. Both are set to UK English. Screenshot attached.

Hi @cizict - if you reload the page this should be back to showing up in the Irish locale. You’ll just need to reload the page.

Very sorry about that, we had a temporary issue with date formatting.

Let us know if they’re still showing this way, and send us the link to this page and we can investigate

Hi Dara,

Thanks for coming back to me so promptly. Still getting the same issue i’m afraid. I’ve always had this issue i think - only just getting around to reporting it.

Here is the link to the page:
https://cizict.noloco.co/call-log

That’s showing up correctly for me @cizict

What language is your computer set to? If it’s US-English then it will show up as the format in your screenshot.

image

Hey,

For the benefit of other users - i am using Windows 10 Home. Language was set to US English. Date/Time and Region were all set to English Ireland. I could not change the Language from US English until i downloaded the Language pack for English Irish. Then was prompted to sign out/back in again. This has not fixed the problem. I’ll try a restart later and report back.

1 Like

This is what we (and most sites that support multi formats) use to determine date formats, so after a restart it should behave correctly

Hello,

Still having this problem. Can confirm that the Windows sys. language is English Irish. Since restarted my PC a number of times and no change. Alos confirmed that browser is in English UK. I’m not having this issue with any other web based programs.

What result do you get when you run this in the JavaScript console in your browser?

Intl.DateTimeFormat().resolvedOptions().locale

It should look something like this:

image

Hi Darragh,

Thanks for that - yep, it was set to en-US. Fixed now.

Notes for anyone else that has this problem:
I fixed this (in Chrome) by adding UK English as a language (Settings → Languages). Before the Language was set to UK English (for dictionary spelling), but adding UK English as another language and setting that to default did the trick. Screenshot below illustrates i hope:

Thanks for the detailed fix @cizict

I’m surprised about this to be honest, but at least we were able to get to the bottom of it.

1 Like