Relative dates and UTC

Hi, maybe a bug, maybe me. After the clocks changed here (UK) the relative dates are always in front.

Default layout:

relative Dates

I have tried both enabled/disabled for consistent time.

Hi @garyGHL - is this using the relative date formatting in Noloco?

It is probably best to not use a consistent time zone for this, but it will depend on your setup

If you want to send us the URL to this page we can investigate it for you. Just send me a DM

In your example, the first date is 2024-04-08T15:26:53.000Z which is in 40 minutes from now.

Time in UTC


So I believe this is working correctly, so long as you have “Use a consistent time zone” checked

No, if you look at you can see a lead that was put on at 15:26 is set as ‘In 25 minutes’ use relative values. So its adding an hour on. It stays the same regardless of whether I use consistent or not.

The raw value is 2024-04-08T15:26:53.000Z which is GMT.
I believe you are in GMT+1 @garyGHL so that time would be 16:26 when viewed in your local time, which was in 25 minutes when you reported it.

This is because you have “Use a consistent timezone set”

Seems to be working now, was it something I did? Just so I know for the Autumn change.









Did you change the field back to not use a consistent timestamp?
You should keep them in local time basically, almost always.

This guide explains the impact of setting the date field’s timezone to GMT, and when you might need it.