Visibility Condition Satisfied But Action Button Not Showing

Hi, I never had this issue before. I looked into every possible reason why this is happening and can’t seem to figure it out.

The green Submit button is configured to show only when the logged in user’s “can submit deals” field is set to True.

But many of my users (for example, Morris Mason) have this set to true and still the Submit button is not showing up for them.

Here’s an example URL:

When viewing as Morris, even in your screenshot, you can see the problem.

The shield next to the field name tells you that the user you’re viewing as does not have permission to read this field.


And sure enough, that value is not enabled for the Manager role

You can review them here:

Thank you for diagnosing the issue.

My confusion was that I thought the filter would evaluate to True even though the user couldn’t read that field.

I didn’t know permissions were that strict. Thanks again.

The visibility rules are calculated when the app is loaded, when the app is loaded the data for those rules is fetched from the API

If the user doesn’t have permission to read those fields then the data will be empty when fetched from the API

Otherwise you would leak sensitive information

So yes, keep an eye out for those permission errors

1 Like